When trying to build gnuradio 3.1.3 on Ubuntu Karmic (which uses the new, stricter gcc 4.4.1), you will get several errors in different files, like these:

error: ‘stderr’ was not declared in this scope
error: ‘fprintf’ was not declared in this scope

Adding #include <cstdio> will solve this.

Update: Seems like this was reported already 4 months ago on the list. Submitted a patch…

Advertisements