On 08.08.2008 Eric Blossom, instead of watching the Opening Ceremony of the Beijing Olympics, merged the multi-processor scheduler feature branch into the trunk. This added the requirement for libboost 1.35.0

Ubuntu Intrepid includes this new version of libboost, however if you want to build the latest version from source (1.36.0), here are the instructions.

Afterwards, every time you want to build gnuradio from trunk, you have to do:

BOOST_PREFIX=/opt/boost_1_36_0
export LD_LIBRARY_PATH=$BOOST_PREFIX/lib
./configure --with-boost=$BOOST_PREFIX
Advertisements